워드프레스 설치중… cURL error 35가 나올 때.

WP HTTP Error: cURL error 35: error:04091068:rsa routines:INT_RSA_VERIFY:bad signature
라는 에러가 계속 났었다.
설치환경은
윈도우 서버 2016 (IIS 10), php 5.6, mariaDB 10.1  전부 x64.

아무리 찾아도 답이 안나오고 설정도 뭐 하라는거 이것저것 다 넣어봤는데도 허사.
혹시나… 하고 PHP를 5.5로 다운그레이드 하니까 아주 멀쩡하게 잘 돌아간다.
워드프레스 이벤트에는 RSS 오류로 같은 오류가 계속 있었는데, 워드프레스를 영어로 설정할 때는 제대로 나왔다. 아마 캐시가 된 듯. 어차피 세팅을 하나도 못 했으니 전부 날리고 재설치 하니 제대로 뜬다. 정말 주말 다 날리고 짬짬히 계속 찾아봤는데 이런 호환성 문제였다니.. 게다가 php 5.6 이하 쓰는 사람들이 훨씬 많으니 별 말이 없었지. 에휴.
텍스트큐브가 훨씬 좋은데, 뭐든지 유료에다 한국에 맞는 세팅도 따로 해야하는 워드프레스에 비하면…

요약.
wordpress 에는 php 5.5를 쓰자.

댓글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다